Pip: listando las dependencias desactualizadas

Trabajando con Django, quería tener todos los packages que han sido actualizados al día de hoy, pero antes, quería ver cuales estaban desactualizados y que versión era la ultima disponible, para ello pip nos provee de una opción  y es pasando el comando list al momento de listar los packages instalado. Haciendo uso del --help , podemos conocer las opciones:

» pip list --help

List Options:
  -o, --outdated  List outdated packages (excluding editables)

En el anterior resumen nos muestra que con hacer simplemente pip list --outdated , o bien si son muy flojos, con hacer pip list -o se puede conocer la versión instalada en nuestro entorno así como la ultima versión disponible:

» pip list --outdated
pilkit (Current: 1.1.5 Latest: 1.1.6)
django-modeltranslation (Current: 0.6.1 Latest: 0.7.2)
django-imagekit (Current: 3.0.4 Latest: 3.1)
django-suit (Current: 0.2.4 Latest: 0.2.5)
Django (Current: 1.5.2 Latest: 1.6.1)
Pillow (Current: 2.0.0 Latest: 2.2.2)